Wahoo Kickr FE-C ANT+ Control / Calibration



  • Hiya!

    Just DL'd and created a workout for myself. Got everything paired. However, MT doesn't seem to control my watts. I've tried to calibrate several times and nothing happens in the calibration window - just s "Calibration in progress..." message and nothing else.....

    I've searched the forums and there doesn't seem to be anything on how to calibrate a trainer. Or how to get MT to control the watts of my trainer.

    Any help is appreciated . FWIW, I'm a TrainerRoad user but am leaving that platform because it's just more than I need for the money. I need an app that allows importing and creation of workouts and controls my Kickr. Thanks!



  • I am having the same problem with a Kinetic NEW Control T-6300 resistance unit.
    Pairing appears to work using Ant+ FE-C trainer but I don't get any resistance control.
    I have tried both versions of MaximumTrainer, 3-04 and 3-05, for Windows available
    in the download section.
    I am running Windows 10 64-bit.

    Note that this trainer works without problems using TrainerRoad PC and Android,
    Rouvy PC - android not tested, GoldenCheetah PC Windows version and of course the 'Kinetic Fit'
    android app.
    So I am convinced that the trainer isn't causing the problem.

    NOTE: I have the 'Control Trainer Resistance (FE-C trainer)' turned on in preferences.

    Maximum Trainer looks awesome and I would very much like to give it a try.

    thanks for any help



  • I have the same problem. I don't think MT works with the Kickr.



  • I have the Wahoo KICKR CORE and work very good with resistance control



  • Hey guys, sorry for the late reply.
    We use the standard ANT+ FE-C control protocol.
    I know some early model had custom protocols that are different, if you can update your trainer firmware and try again

    Cheers,
    Max



  • I'm having the same problem with no resistance, I can only match the set watts using speed.
    I am using MAC OS X 10.44.2 with a generic Ant+ dongle with a Garmin HRM and bike computer and the Wahoo Fitness application. My setup works with other indoor cycling applications, all devices agree on watts, speed, cadence and HR and when the required watts for resistance goes up and down I feel the difference in peddling. Also all my devices are successfully registered and selected.
    When I go through a session in Maximum Trainer I feel no resistance, this is in one of the sessions included in Maximum Trainer and also one I made myself.
    I do have the FE-C which I believe is correct for a Wahoo Kickr v2 with latest firmware installed.
    I have tried enabling and disabling and different options in selecting devices in the Ant, remove and only pair individual devices.
    I like the idea of the program and would be happy to donate but it has to work properly.
    Looking forward to an answer that make it work.
    Thanks
    Munsie



  • @Munsie_1963

    Sadly I don't have a Kickr to test. The software was tested with SimulANT+, that provide a virtual FE-C trainer, and the resistance is controlled there. I know other trainer that respects FE-C protocol have no issue also (NEO, etc.)
    I suggest you contact Wahoo support, and ask them if they use a custom FE-C protocol, or if their trainer pass the SimulANT+ test.

    Cheers,
    Max


Log in to reply