Bkool



  • what about Bkool



  • hi, i connected successfully my Bkool Trainer Classic, but the software does not control the trainer resistance. What I am doing wrong?

    Also, I have a Quarq powermeter, I dont know which power is showed in the workout, trainer or powermeter?

    thanks



  • I have to say that i correctly used the bkool trainer under fe-c protocol with other softwares and directly with my garmin edge 820.

    I really like to try MaximumTrainer!

    thanks!



  • Hey There,

    Is the trainer labelled as a FE-C Trainer? (ANT+ label logo on it?)
    If so, I will try to see what is wrong, we use the standard implementation of the FE-C protocol, it should work with any FE-C trainer that is following the protocol.
    Let me know,

    Cheers,
    Max



  • yes, ant+ fe-c

    i can control the trainer with my garmin edge 820, setting a target power in W and the resistance follows.

    The software recognices the trainer without problems, but in the workout, it does not control the resistance. Maybe I am doing something wrong, I dont know.

    BTW I use a macbook pro with OSX. Now I will install the windows version and try. But I rather prefer using my mac with osx.

    thanks!



  • tested windows version, still no trainer resistance control :(

    i tested with exact configuration with PerfPro Sim and worked well.

    In OSX i have tested with TrainerRoad and worked well.

    Look at the screenshot:

    alt text



  • Thanks for the info!

    Have you double checked that this option is enabled?
    Top Menu, Preferences, ANT+, "Control Trainer Resistance (FE-C Trainer)"
    Let me know,
    Cheers



  • I think I know why, If you don't use your normal power meter, it should control the resistance.
    Try unchecking the power meter in the ANT+ page and let me know.
    Max



  • Hi max,

    yes i checked and tried both checked and unchecked "Control Trainer Resistance (FE-C Trainer)"

    also tried disabling the powermeter sensor. I will try deleting the sensor.



  • @admin Hi max, I have deleted the power sensor but there is no effect, still no resistance control:

    alt text



  • Hey, thanks for testing.

    Do you have the "Bkool Smart Pro" ?
    https://www.thisisant.com/directory/
    You can check on this website on the left, under Directory, Profiles, Fitness Equipement Control (FE-C)
    And I don't see the Bkool there, only the BKool smart pro.

    Let me know,
    Max



  • Hi max,

    I have the "Bkoll classic" or "Bkool trainer classic", which originally did not have FE-C protocol, but after a firmware update, it got it.

    After that, i have successfully used it under ant+ fe-c protocol with my garmin 820, PerfPro sim, TrainerRoad, Zwift.

    Maybe it is not listed under your database.

    I will be happy to provide any detail or debug information for you if you need it.

    thanks!



  • Hey thanks for the info.

    So you have the latest firmware for the BKoll classic? perfect!
    I suspect theses apps already supported the BKoll classic before the firmware upgrade.
    It may use a slightly different protocol since it is not listed on the ANT+ directory page.
    I will try to get in touch with the manufacturer to know more.


    email sent to their support :
    Hi there,

    I have numerous clients using your trainer that are having problem controlling the resistance with the BKool classic. They have upgraded the firmware to FE-C control.

    Is the trainer using the ANT FE-C protocol correctly?
    I am not sure since it is not listed under FE-C :
    https://www.thisisant.com/directory

    They can pair the trainer, but when the software send load to the trainer, it is not adjusting the resistance of the trainer. Is it possible to check with the ANT+ Simulator, send load to the trainer, to see if the trainer is compatible.
    https://www.thisisant.com/developer/resources/tech-bulletin/ant-simulator

    Thank you!



  • Hi max,

    thanks for the patience.

    No i don't think that because before the firmware upgrade, neither my garmin or the apps are able to see the trainer. They just did not find it. After the upgrade, the trainer start to appear as smart trainer under fe-c

    I hope the guys at Bkool answer!



  • Hey Raberrio,

    Is your trainer on version 2.04 ?
    Quote from support :
    To know if the trainer already has that version, please click on the simulator's Settings button, at the top of the screen. Down in the menu you will find "About the App", click on it. If your trainer is paired, you will see its firmware version in the Sensors section. It must be 2.04

    Let me know,
    Thanks



  • Yes. It is v2.04

    I just confirmed that in the bkool app



  • hi! any luck with this? thanks!



  • Hey there,

    Finally got an answer from support. The told me it is not labelled FE-C trainer since it was supported later on.
    It is hard to investigate since I don't have the trainer to test.

    If you have the time and want to test with your trainer.
    There is a software called "SimulANT+ 2.0" available here
    You can then add a new FE-C trainer and try sending load to your trainer, see if your trainer accepts it

    Unfortunately I don't have much time to invest in this, as all the other FE-C trainer work out of the box. I will not invest time to support trainer that are not standard anymore. Last time I did (CompuTrainer), it took a long time and was not profitable since non standard trainer are fading out.

    Have a great day!
    Max



  • thanks, i will try the simulant



  • I've been using bkool pro trainers for a few days now and I can verify that they are working as expected. I use the studio mode and the only problem I'm having is the consistency of the ant+ connection. Make sure you have the 3.1 firmware on the trainer and that it is fe-c enabled. To check this goto bkool simulator and settings/about to see the system specs. Near the bottom of the page it will display the info about the connected trainer and should say 3.1 and fe-c. If not go through the firmware update process until it doeas. Good luck!



  • @amillett67 As a follow up: Connection issues solved! Studio mode with 10 Bkools worked great by using 4 USB 10 foot extension cables to move the 4 dongles closer to trainers and away from PC.


Log in to reply